Resolved
Safaricom M-Pesa has resolved the service disruption. Both deposits and withdrawals are now processing normally.
Identified
Safaricom m-pesa is currently experiencing intermittent service interruptions due to issues at Safaricom. During this time both deposits and withdrawals with m-pesa may be delayed or fail. We are monitoring and will inform users when resolved.
Identified
Withdrawals to M-Pesa mobile wallets in Kenya are currently delayed. We are actively collaborating with our local payment partner to resolve this issue promptly.