Resolved
The issue has been resolved - withdrawals are now going through as expected.
Monitoring
Delayed transactions are now being processed and we have confirmation of them hitting mobile wallets.
Identified
Our local payment partner has implemented a resolution for this issue. Some transactions are still delayed, but we expect them to begin processing shortly.
Identified
Withdrawals to M-Pesa mobile wallets in Kenya are currently delayed. We are actively collaborating with our local payment partner to resolve this issue promptly.