Resolved
We’re happy to share that the issue has been resolved - withdrawals are now going through as expected.
Investigating
Withdrawals to M-Pesa mobile wallets in Kenya are currently delayed. We are actively collaborating with our local payment partner to resolve this issue promptly.