Resolved
We are pleased to inform you that service to MTN has been restored across all regions.
Investigating
Please be informed that we are currently experiencing a service interruption affecting MTN services across all regions in Africa. Our team is actively working with MTN to restore services as quickly as possible.