Very high demand causing intermittent issues
Resolved
Degraded performance

Mobile Money Wallet Payments Restored


Deposits and withdrawals to M-Pesa and all other mobile money wallets in Africa are now fully operational and should not experience delays.

We appreciate your patience during this time and will continue to closely monitor our systems.

Wed, Dec 4, 2024, 03:30 PM
3 weeks ago
Affected components
App
Sling Links
Transactions
Add Money
Remove Money
Updates

Resolved

Mobile Money Wallet Payments Restored


Deposits and withdrawals to M-Pesa and all other mobile money wallets in Africa are now fully operational and should not experience delays.

We appreciate your patience during this time and will continue to closely monitor our systems.

Wed, Dec 4, 2024, 03:30 PM
5d earlier...

Identified

Payments to mobile money wallets are currently unavailable.

Deposits and withdrawals to M-Pesa and other mobile money wallets on Africa are severely limited as our partner works to keep up with the volume. Already pending transactions will be process but will have significant delays.

We are working to get everything back to normal and will update when we have more information.

Thu, Nov 28, 2024, 10:18 PM
6h earlier...

Identified

We have implemented a signup queue system so that we allow one new user signup per second. Users will be held in line and allowed through at this rate. You can safely close the app and reopen it and your place in line will be maintained.

Thu, Nov 28, 2024, 03:48 PM
2h earlier...

Identified

The app and related services are mostly holding up well now after we've done work with our partners and infrastructure to support increased load.

Adding and removing money in Kenya is delayed and due to the dramatic volume increase we're experiencing new users signing up now should expect up to a 24 hour delay before their first fiat transaction completes.

Thu, Nov 28, 2024, 12:59 PM
3h earlier...

Identified

We have significantly scaled our platform and generally restored stability. We continue to be rate-limited by one third-party provider and are making changes to our own software to reduce our calls to them.

Thu, Nov 28, 2024, 09:45 AM

Identified

Updating status to go from Investigating -> Identified. We continue to find and resolve problems as we scale.

Thu, Nov 28, 2024, 09:38 AM

Investigating

We have completed a number of actions to improve scalability and believe we are seeing and will continue to see an improvement in reliability as we scale:

  • We've provisioned much larger database instances and more of them, scaling both horizontally and vertically

  • We have also increased our compute instances, scaling horizontally and vertically

  • We have shed load from some non-essential services and noisy logging

  • We have worked with our third-party partners to increase rate limits across critical path services and to upgrade our instances with those third-party partners were necessary

We are still facing an issue with rate limiting with our IDV and KYC partner and are making changes to our service design so that we call them less frequently while maintaining safety and security.

Thu, Nov 28, 2024, 09:37 AM
1h earlier...

Investigating

Sling Money has gone viral and the graphs have gone straight up. This is causing strain on various aspects of our platform and operations, and we are working to scale up as fast as we can. We'll be able to handle this demand no problem, but the speed of the change has caused some issues.

Thu, Nov 28, 2024, 07:43 AM